Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 09, 2019 - 04:15 EDT
Investigating
We will be performing an emergency restart on Paladins Crossplay. We apologize for the inconvenience and will have the game back up shortly.
Posted 13 days ago. Sep 09, 2019 - 03:56 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).