Smite Crossplay Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. May 29, 2019 - 19:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 29, 2019 - 18:59 EDT
Investigating
We are investigating an issue preventing players from being able to log in. We apologize for the inconvenience and thank you for your patience.
Posted 3 months ago. May 29, 2019 - 18:35 EDT
This incident affected: Smite (Smite PC, Smite Xbox, Smite Switch).