Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Paladins PC incident has been resolved. #PaladinsPC
Posted 3 months ago. Mar 18, 2017 - 06:33 EDT
Update
We are currently investigating this Paladins PC issue.
Posted 3 months ago. Mar 18, 2017 - 06:03 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Mar 18, 2017 - 05:42 EDT