Smite PC/PS4/Switch/Xbox Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This login issue for #Smite #PC, #PS4, #Switch, #Xbox has been resolved.
Posted 3 months ago. Feb 06, 2019 - 09:44 EST
Investigating
We are currently investigating an issue with #Smite #PC, #PS4, #Switch, & #Xbox logins.
Posted 3 months ago. Feb 06, 2019 - 08:34 EST
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox).