Realm PC/XBOX Logins
Incident Report for Hi-Rez Studios, Inc
Postmortem

Postmortem

At 12:07 AM EST we encountered a technical issue which impacted logins to Realm PC and Xbox. Our tech team implemented a fix and restarted the game. After the restart Realm fully recovered at 1:08 AM. The incident lasted 60 minutes. We apologize for the inconvenience.

Posted 15 days ago. Apr 08, 2019 - 12:35 EDT

Resolved
This incident has been resolved.
Posted 16 days ago. Apr 08, 2019 - 01:15 EDT
Monitoring
Login issues have been resolved and we are monitoring
Posted 16 days ago. Apr 08, 2019 - 01:08 EDT
Investigating
We are currently working on issues with logins for Realm PC/XBOX environment.
Posted 16 days ago. Apr 08, 2019 - 00:54 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox).