Logins will be paused momentarily to enable content on Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue has been resolved
Posted over 1 year ago. Nov 17, 2015 - 07:27 EST
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Nov 17, 2015 - 07:13 EST