Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 16, 2017 - 14:25 EST
Identified
We are currently working on issues logging in on Paladins PC.
Posted 2 months ago. Jan 16, 2017 - 14:11 EST
Monitoring
We have resumed logins to Paladins PC. #Paladins
Posted 2 months ago. Jan 16, 2017 - 13:35 EST
Identified
We are currently working on restoring Paladins PC service. #Paladins
Posted 2 months ago. Jan 16, 2017 - 13:31 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 2 months ago. Jan 16, 2017 - 13:26 EST
This incident affected: Paladins PC.