Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #Smite #PS4 have been resolved.
Posted 19 days ago. Jun 05, 2017 - 20:06 EDT
Update
We are performing another emergency restart for #Smite #PS4. The game will be up shortly.
Posted 19 days ago. Jun 05, 2017 - 19:23 EDT
Identified
We are performing an emergency restart for #Smite #PS4. The game will be up shortly.
Posted 19 days ago. Jun 05, 2017 - 18:54 EDT
Investigating
We are investigating an issue with #Smite #PS4
Posted 19 days ago. Jun 05, 2017 - 18:41 EDT
This incident affected: Smite PS4 - North America / Europe.