Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted 13 days ago. Aug 04, 2017 - 18:40 EDT
Monitoring
Emergency restart for #Smite #Xbox is complete; we are continuning to monitor. Apologies for the inconvenience.
Posted 13 days ago. Aug 04, 2017 - 18:23 EDT
Identified
We are performing an emergency restart for #Smite #Xbox. The game will be back up shortly.
Posted 13 days ago. Aug 04, 2017 - 18:12 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 13 days ago. Aug 04, 2017 - 18:04 EDT
This incident affected: Smite Xbox - North America / Europe.