Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 09, 2016 - 18:43 EST
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted almost 2 years ago. Feb 09, 2016 - 18:33 EST