We will be performing an emergency restart for #HandOftheGods
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart for #HandOftheGods has been completed.
Posted 5 months ago. Jun 10, 2017 - 19:12 EDT
Investigating
We will be performing an emergency restart for #HandOftheGods
Posted 5 months ago. Jun 10, 2017 - 19:03 EDT
This incident affected: Smite Tactics.