Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 11, 2018 - 23:20 EDT
Monitoring
Restart is complete. We will continue to monitor for any further issues.
Posted 4 months ago. Aug 11, 2018 - 22:53 EDT
Identified
We are performing an emergency restart for #Smite #Xbox. The game will be back soon.
Posted 4 months ago. Aug 11, 2018 - 22:43 EDT
This incident affected: Smite (Smite Xbox).