Paladins PC Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency Restart of #Paladins #PC has concluded.
Posted 9 days ago. Feb 10, 2018 - 18:04 EST
Identified
We will be performing an emergency restart for #Paladins #PC
Posted 9 days ago. Feb 10, 2018 - 17:48 EST
This incident affected: Paladins PC.