Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smitepc
Posted 2 months ago. Feb 26, 2017 - 00:42 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Feb 25, 2017 - 23:57 EST
This incident affected: Smite PC - North America / Europe.