HiRez Games - Issue with Xbox in-game sales
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jan 18, 2020 - 15:19 EST
Investigating
Xbox is experiencing an issue with in-game sales. #Xbox #Smite #Paladins #RealmRoyale
Posted Jan 18, 2020 - 13:18 EST
This incident affected: SMITE (SMITE Xbox), Paladins (Paladins Xbox), and Realm Royale (Realm Royale Xbox).