Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 15, 2016 - 19:53 EST
Identified
Xbox Live is having issues.... You may have trouble with Parties and Joining Friends
http://support.xbox.com/en-US/xbox-live-status?icid=furl_status
http://downdetector.com/status/xbox-live
#smite
Posted almost 2 years ago. Feb 15, 2016 - 18:02 EST
Update
We are Investigating #Smite
Posted almost 2 years ago. Feb 15, 2016 - 17:59 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted almost 2 years ago. Feb 15, 2016 - 17:57 EST