Paladins PS4 Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue impacting matchmaking on #Paladins #PS4 has been resolved.
Posted Jul 19, 2018 - 21:38 EDT
Monitoring
A fix has been implemented, and logins have resumed. We will continue to monitor.
Posted Jul 19, 2018 - 20:50 EDT
Identified
We are implementing a fix for the issue. Players will not be able to login during this time.
Posted Jul 19, 2018 - 20:43 EDT
Investigating
There is currently an issue that is affecting matchmaking on Paladins PS4. We are currently investigating.
Posted Jul 19, 2018 - 20:40 EDT
This incident affected: Paladins (Paladins PS4).