Paladins POB 12 chest problems
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 26, 2016 - 12:17 EST
Investigating
We are investigating #paladins
Posted almost 2 years ago. Jan 26, 2016 - 11:45 EST