Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite XBOX has been restored. #SMITE #XBOX
Posted 9 months ago. Mar 22, 2017 - 23:06 EDT
Update
We had a major database server error on smite xbox and we expect to be down for 1 to 2 hrs, sorry for the inconvenience #SmiteXBOX
Posted 9 months ago. Mar 22, 2017 - 22:08 EDT
Identified
We are currently working on restoring Smite XBOX. #SMITE #XBOX
Posted 9 months ago. Mar 22, 2017 - 21:43 EDT
Update
We currently have suspended logins #SmiteXBOX
Posted 9 months ago. Mar 22, 2017 - 21:36 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Mar 22, 2017 - 21:22 EDT
This incident affected: Smite Xbox - North America / Europe.