Limiting Logins Paladins PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed, and the issue with #Paladins #PC has been resolved.
Posted 10 days ago. Dec 05, 2017 - 16:52 EST
Identified
We are limiting logins temporarily for #Paladins #PC. We will update accordingly.
Posted 10 days ago. Dec 05, 2017 - 16:36 EST
This incident affected: Paladins PC.