Smite PC Oceania Servers currently unavailable
Incident Report for Hi-Rez Studios, Inc
Resolved
Oceania Servers are now back online #smite
Posted about 1 year ago. Feb 16, 2016 - 13:15 EST
Identified
Currently Oceania Servers are not available, we will update when they are back online #smite
Posted about 1 year ago. Feb 16, 2016 - 07:19 EST