Pausing Logins on Smite PC to make adjustments
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 16, 2016 - 12:47 EST
Investigating
We are pausing logins to adjust queues for smite PC.
Apologies for the inconvenience.
#SMITE
Posted almost 2 years ago. Feb 16, 2016 - 12:36 EST