SMITE PC Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC is back up and runnning. #SMITE
Posted 9 months ago. Sep 25, 2016 - 16:56 EDT
Update
We are still investigating this Smite PC issue#smite
Posted 9 months ago. Sep 25, 2016 - 08:27 EDT
Update
We are currently still working on SMITE PC issues.
Posted 9 months ago. Sep 25, 2016 - 05:33 EDT
Investigating
We are currently working on the outage for SMITE PC. #SMITE
Posted 9 months ago. Sep 25, 2016 - 05:28 EDT