Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 17, 2016 - 16:07 EDT
Monitoring
Logins have resumed for #Smite on #Xbox
Xbox Live may still be having issues preventing some users from logging in.
http://support.xbox.com/en-US/xbox-live-status
Posted about 1 year ago. Aug 17, 2016 - 13:14 EDT
Identified
We will be performing an emergency restart for #Smite on #XBox.
Posted about 1 year ago. Aug 17, 2016 - 12:46 EDT
Update
We are currently investigating issues effecting logins in the #Smite #Xbox environment.
Posted about 1 year ago. Aug 17, 2016 - 12:45 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Aug 17, 2016 - 12:32 EDT