Smite PC - Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC has been restarted; game servers back up and taking traffic.
Posted about 1 year ago. Feb 02, 2016 - 14:14 EDT
Investigating
#SMITE PC will be going down temporarily for an emergency restart...back up shortly.
Posted about 1 year ago. Feb 02, 2016 - 13:55 EDT