Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved. #paladins
Posted about 1 year ago. Jul 05, 2016 - 01:06 EDT
Identified
We are currently experiencing issues with purchases on pc, we are working to fix the issue.#paladins#smite
Posted about 1 year ago. Jul 05, 2016 - 00:21 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 year ago. Jul 04, 2016 - 23:54 EDT