Smite Crossplay Server Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 22, 2019 - 00:54 EDT
Monitoring
Emergency restart is now complete.
Posted about 1 month ago. Aug 21, 2019 - 23:18 EDT
Update
We will be performing an emergency restart of Smite Crossplay
Posted about 1 month ago. Aug 21, 2019 - 22:48 EDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Aug 21, 2019 - 22:38 EDT
This incident affected: Smite (Smite PC, Smite Xbox, Smite Switch).