Smite PC - Restarting a component in the game
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 16, 2016 - 14:58 EDT
Investigating
We will be restarting a component of the game in 5 min
Those of you in a party may need to re-log and re-party
#smite
Posted about 1 year ago. Feb 16, 2016 - 14:49 EDT