Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Smite PS4 incident has been resolved. #SmitePS4
Posted about 2 months ago. Aug 08, 2017 - 14:53 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. Aug 08, 2017 - 13:13 EDT