Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 4 months ago. Feb 21, 2017 - 20:36 EST
Identified
Steam is undergoing routine maintenance. https://steamstat.us #SmitePC
Posted 4 months ago. Feb 21, 2017 - 20:20 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Feb 21, 2017 - 20:10 EST