Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOXincident has been resolved# smite
Posted almost 2 years ago. Mar 10, 2016 - 03:50 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted almost 2 years ago. Mar 10, 2016 - 03:35 EST