Paladins PC Down
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 10, 2019 - 19:46 EST
Update
We are continuing to monitor for any further issues.
Posted 6 months ago. Feb 10, 2019 - 19:09 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Feb 10, 2019 - 19:09 EST
Identified
Paladins PC is down temporarily. We are working to bring the game back online as soon as possible.
Posted 6 months ago. Feb 10, 2019 - 18:57 EST
This incident affected: Paladins (Paladins PC).