Paladins PC - Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins #PC incident has been resolved.
Posted Nov 14, 2018 - 13:36 EST
Monitoring
The #Paladins #PC restart has been completed. We are monitoring the results.
Posted Nov 14, 2018 - 12:59 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2018 - 12:40 EST
Identified
We are temporarily limiting logins for #Paladins #PC to address the issue. We will update accordingly and apologize for the inconvenience
Posted Nov 14, 2018 - 12:38 EST
Monitoring
The #Paladins #PC restart has been completed. We are monitoring the results.
Posted Nov 14, 2018 - 12:35 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2018 - 12:17 EST
Investigating
We are currently looking at login issues with Paladins PC.
Posted Nov 14, 2018 - 12:17 EST
This incident affected: Paladins (Paladins PC).