Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC service has been restored
Posted 3 months ago. Dec 20, 2016 - 16:21 EDT
Identified
We are currently working on restoring service for Smite PC
Posted 3 months ago. Dec 20, 2016 - 16:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Dec 20, 2016 - 16:09 EDT
This incident affected: Smite PC - North America / Europe.