Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This SMITE PC incident has been resolved
Posted about 1 year ago. Mar 23, 2016 - 01:31 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 22, 2016 - 23:32 EDT