Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The #SMITE PC issue has been resolved.
Posted 10 months ago. Oct 26, 2016 - 18:59 EDT
Update
We will be restarting the #SMITE PC environment.
Posted 10 months ago. Oct 26, 2016 - 18:33 EDT
Identified
Identified: The Smite issue has been identified and a fix is being implemented#smite
Posted 10 months ago. Oct 26, 2016 - 18:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Oct 26, 2016 - 17:52 EDT