Paladins PC Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 17 days ago. Jun 06, 2018 - 11:27 EDT
Identified
#Paladins PC is down for patch maintenance
Posted 17 days ago. Jun 06, 2018 - 09:51 EDT
This incident affected: Paladins (Paladins PC).