Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 03, 2017 - 12:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jul 03, 2017 - 12:06 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. Jul 03, 2017 - 11:45 EDT