Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 09, 2019 - 22:13 EDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jun 09, 2019 - 21:42 EDT
Identified
We will be performing an emergency restart of Paladins Crossplay. The game will be back shortly.
Posted 2 months ago. Jun 09, 2019 - 21:39 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).