Paladins PC Queue Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 18, 2018 - 17:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2018 - 17:25 EDT
Identified
We are investigating the issues affecting queues in #Paladins #PC
Posted Jul 18, 2018 - 17:20 EDT
This incident affected: Paladins (Paladins PC).