Paladins PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins #PS4 issue has been resolved.
Posted 7 months ago. Mar 05, 2018 - 19:04 EST
Monitoring
The emergency restart for #Paladins #PS4 has been completed. We are monitoring the results.
Posted 7 months ago. Mar 05, 2018 - 17:09 EST
Identified
We are performing an emergency restart for #Paladins #PS4. Game will be back up shortly.
Posted 7 months ago. Mar 05, 2018 - 16:53 EST
Investigating
Automated services have detected a possible problem with #Paladins PS4. We are investigating.
Posted 7 months ago. Mar 05, 2018 - 15:59 EST
This incident affected: Paladins (Paladins PS4).