Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart of #Tribes Ascend is complete.
Posted 9 months ago. Jul 18, 2016 - 18:16 EDT
Identified
Emergency restart of the #Tribes Ascend environment is under way; will advise when complete.
Posted 9 months ago. Jul 18, 2016 - 17:35 EDT
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 9 months ago. Jul 18, 2016 - 17:27 EDT