Paladins PC Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 24 days ago. Sep 23, 2018 - 22:42 EDT
Monitoring
The restart has been completed, and logins have resumed. We will continue to monitor.
Posted 24 days ago. Sep 23, 2018 - 20:43 EDT
Identified
We will be performing an emergency restart of Paladins PC. The game will be back shortly.
Posted 24 days ago. Sep 23, 2018 - 20:30 EDT
Investigating
There is currently an issue affecting logins on Paladins PC. We are currently investigating, and will update the situation as needed.
Posted 24 days ago. Sep 23, 2018 - 20:23 EDT
This incident affected: Paladins (Paladins PC).