Realm Royale Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jul 30, 2018 - 17:24 EDT
Monitoring
Logins have resumed. We will continue monitor.
Posted about 2 months ago. Jul 30, 2018 - 15:11 EDT
Identified
We will be temporarily pausing logins for Realm Royale. While we address an issue that is affecting matchmaking.
Posted about 2 months ago. Jul 30, 2018 - 15:08 EDT
This incident affected: Realm Royale (Realm Royale PC).