Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins incident has been resolved#paladins
Posted 5 months ago. Oct 16, 2016 - 10:31 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. Oct 16, 2016 - 10:05 EDT