Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PC has been restarted and logins resumed.
Posted about 2 months ago. Aug 09, 2017 - 08:51 EDT
Update
We will be bringing #Paladins #PC down for emergency maintenance
Posted about 2 months ago. Aug 09, 2017 - 08:05 EDT
Identified
We will be limiting logins briefly for #Paladins
Posted about 2 months ago. Aug 09, 2017 - 07:38 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Aug 09, 2017 - 07:35 EDT
This incident affected: Paladins PC.