Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart has been completed.
Posted 4 months ago. Jun 29, 2019 - 08:43 EDT
Investigating
We are performing an emergency restart on Paladins Crossplay.
Posted 4 months ago. Jun 29, 2019 - 02:35 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).