Logins Paused Paladins PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins for #Paladins on #PC have resumed.
Posted 2 months ago. Mar 17, 2017 - 14:23 EDT
Identified
Logins will be paused momentarily on #Paladins #PC.
Posted 2 months ago. Mar 17, 2017 - 14:05 EDT
This incident affected: Paladins PC.