Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 19, 2016 - 12:45 EST
Monitoring
We are currently working to restore logins on #Paladins.
We apologize for the inconvenience.
Posted 7 months ago. Nov 19, 2016 - 09:50 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Nov 19, 2016 - 09:45 EST