Smite XBox 3.6 Patch Delayed
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE XBox 3.6 is open to the public; apologies for the inconvenience
Posted 12 months ago. Apr 26, 2016 - 09:14 EDT
Monitoring
Microsoft has released the #SMITE XBox patch; we are in final verification phase now and will be coming up soon
Posted 12 months ago. Apr 26, 2016 - 08:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 12 months ago. Apr 26, 2016 - 08:21 EDT
Investigating
#SMITE XBox is delayed coming back up due to issues with Microsoft releasing the patch; the game will come back up as soon as possible.
Posted 12 months ago. Apr 26, 2016 - 08:21 EDT